Merhabalar.

Dart eğitimlerimizi büyük orandan bitirdiğimize göre artık Flutter SDK’sını ve Dart dilini kullanarak adım adım mobil uygulamalarımızı geliştirmeye giriş yapabiliriz.

Bir mobil uygulama geliştirebilmek için tabii ki başlangıçta kurmamız gereken SDK’lar, uygulamalar, yapmamız gereken ayarlar var.

Bu yazımızın konusu Power Shell kurulumu olacak.

Aşağıdaki siteye gittiğimizde bize Flutter ile çalışabilmek için gerekli uygulamalardan bahsediyor.

https://flutter.dev/docs/get-started/install/windows

Onlardan ilki Power Shell 5.0 veya üzeri bir sürümünün kurulması ya da var olması.

Windows 8 veya üzeri bir işletim sisteminiz var ise zaten power shell’e sahipsinizdir.

Arama çubuğuna power shell yazıp çalıştırabilirsiniz.

Power Shell’in böyle bir görüntüsü var.

Versiyonunu kontrol etmek için aşağıdaki işlemi yapabilirsiniz.

Açılan ekranda $PSVersionTable yazıp Enter diyoruz.

Şimdi Power Shell hiç yoksa veya 7.x versiyonunu kurmak istiyorsanız okumaya devam ediniz.

Aşağıdaki siteye gidiyoruz.

https://github.com/PowerShell/PowerShell/releases

Release version kararlı sürüm demektir. Gerekli testler geçmiş anlamını taşır. Sayfaya gittiğinizde kararlı sürümün bir üst sürümü de bulunabilir. Ama biz kararlı sürümü indirelim. 

 Sayfada biraz aşağıya inip bu kısmı buluyoruz. Ve gösterilen seçeneği indiriyoruz. 

  Kurulum dosyasını çalıştırıyoruz ve aşağıdaki yönergeleri uyguluyoruz.

Artık PowerShell de hazır. 

İndirdiğimiz versiyonu açıp çalıştırabiliriz.

Bir sonraki yazımızda Git kurulumu ile devam edeceğiz.

İyi çalışmalar.


What's Your Reaction?

hate hate
0
hate
fail fail
0
fail
fun fun
0
fun
geeky geeky
0
geeky
love love
0
love
lol lol
0
lol
omg omg
0
omg
win win
0
win
Murat Bilginer
21 Şubat 1992 Doğumlu. Endüstri Mühendisi olarak Lisansını 2016 yılında tamamlamıştır. Industryolog Akademi - NGenius oluşumlarının kurucusudur. Şu anda kendi şirketi Brainy Tech ile hem Yazılım Hizmetleri Sunmakta Hem de Online Eğitimler Vermektedir.