Eğer (İf) Kullanımı

Elimizde bir veya daha fazla sonuç olduğunda ve bunlara bağlı birkaç koşul olduğunda gidilecek yolu belirlemek için eğer formülünü kullanırız. Diğer bir deyişle  eğer formülü, koşullara bağlı olarak farklı olasılıkların sonucunda yapılacak işlemi seçmemizi sağlar. Bir örnekle bahsedecek olursak elimizde birkaç tane öğrenci olsun. Öğrencilerin not ortalaması 50’nin altında ise sınıfta kalsın; 50 ve üstü ise sınıfı geçsinler.

Bu olayın diyagramını çizelim. Koşullarımız:

  1. 50’nin altı
  2. 50 ve üstü

 

 

Formül =EĞER(koşul; doğruysa; yanlışsa) şeklinde yazılır.

 =EĞER(B2<50;”Sınıfta Kaldı”;”Sınıfı Geçti”) formülü ile B2 hücresindeki notun 50’nin altında ya da üstünde olduğunun kontrolü yapılır. 50 veya üstünde ise öğrenci sınıfı geçer; değilse kalır.

İçe İçe Eğer

 İç içe eğerde, tek eğer kullanımından farklı olarak ikiden daha fazla sonuç vardır. Bir önceki örneği geliştirerek devam edelim. Bir öğrenci matematik dersinde aldığı not 0 – 20 arasında ise başarısız; 20 – 45 arasında ise kötü;   45 – 60 arasında orta; 60 – 80 arasında iyi; 80 – 100 arasında ise pekiyi olsun. Bunun için diyagramı çizersek toplam 5 koşulumuz olur.

 Formül =EĞER(Koşul1;doğruysa;EĞER(Koşul2;doğruysa;…;EĞER(Koşulx;doğruysa;yanlışsa))))

şeklinde yazılır.

VE Kullanımı

Koşullu bir olayda birden fazla koşul var ise eğer içinde ve formülü kullanılır. Örnek olarak bir şirket işçi alımı için başvuranların yaş, askerlik durumu ve eğitim durumuna göre seçim yapsın. İşe alınacak işçilerin yaşının 20’den yukarı, askerlik durumunun yapılmış olmasını ve eğitim durumunu lisans düzeyi olarak belirlesin.

Formül =Eğer(ve(koşul1; koşul2; koşul3); “doğruysa”; ”yanlışsa”) şeklinde yazılır.

=EĞER(VE(B2>=20;C2=”Yapılmış”;D2=”Lisans”);”İşe Alındı”;”İşe Alınmadı”)

Bu tabloda başvuranın işe alınması için üç koşul gösterdik. Bu koşulları B,C,D sütunlarına yazdık. Ve komutunu kullanarak bu üç sütundaki koşullara, başvuranın uyumluluğunu kontrol ettirdik. Başvuran üç koşulda da istenilen durumda ise E sütununa işe alındı; değilse alınmadı yazıldı.

YA DA Kullanımı

Ya da formülü ve formülünden farklı olarak ve formülünde bütün sütunlardaki koşulların sağlanması gerekirken burada belirtilen koşullardan en az birinin doğru olması yeterlidir. Örnek olarak bir önceki tablodan gidelim. Bu sefer işveren koşulları yaşın 20’nin üstünde olması ya da eğitim durumunun en az lise olmasının yeterli olabileceği ilanını versin.

Formül =EĞER(YADA(Koşul1; Koşul2);”Doğruysa”;”Yanlışsa”) şeklinde yazılır.

=EĞER(YADA(B2>=20;D2=”Lise”);”İşe Alındı”;”İşe Alınmadı”)

Burada işe alınan kişilerin yaş ve eğitim durumu koşullarından en az birini yerine getirebilmesi işe alınması için yeterli bir durumdur. Mehmet isimli kişi 20 yaşını dolduramamış olmasına rağmen lise mezunu olması işe alınması için yeterlidir. Fakat Ali isimli kişi bu iki koşuldan birini bile yerine getiremediği için işe alınmadı.

Bu yazımızda Excel’de oldukça sık kullanılan Eğer ve saz arkadaşları Ve, Ya Da formüllerini gördük.

Umarım size faydalı bir yazı olmuştur

Facebook Sayfamizdan Bizleri Takip Edebilirsiniz